Upgrading from a previous version of Perception | Questionmark

Upgrading from a previous version of Perception

Applies to the following products: 
Questionmark Perception
Applies to the following Perception versions: 
Perception 5.7

The upgrade process to Perception 5.7 will vary depending on what version you are currently running and what operating system and database platform it uses.

If you're upgrading from Perception 5.4, please refer to:

Upgrading from Perception 5.4

If you're upgrading from Perception 5.1/5.2, please refer to:

Upgrading from Perception 5.1/5.2

If you're upgrading from Perception 4, you'll likely need to upgrade your operating system and/or database technology before upgrading Perception itself. It is recommended that if you're upgrading from Perception 4 that you upgrade to Perception 5.4 before upgrading to Perception 5.7. For information on how to upgrade to Perception 5.4 from Perception 4, please refer to following section of the Questionmark Perception 5.4 Install Guide:

Upgrading from Perception 4

Questionmark recommend the following resources:

Upgrade required

Useful resources

Upgrading from Windows Server 2000 or 2003

Upgrades to Windows Server 2008 R2 from the following operating systems are not supported:

  • Windows XP, Windows Vista, and Windows 7
  • Windows 2000 Server, Windows Server 2003 RTM, Windows Server 2003 with SP1, and Windows Server 2003

If you are using a Windows version that cannot be upgraded to Windows Server 2008 R2, please refer to:

Recommendations for installing from a version of Windows that can't be upgraded

If Perception is installed on a version of Windows that can be upgraded to Windows Server 2008 R2, please refer to:

Upgrading to Windows Server 2008

Once you have successfully upgraded you operating system, please refer to:

Recommendations for installing from a version of Windows that can be upgraded

Upgrading from Windows XP, Windows Vista, or Windows 7

Upgrading from SQL Server 2005

If you have any difficulties carrying out these upgrades, please contact the software vendor for assistance.

Recommendations for installing from a version of Windows that can't be upgraded

It is recommended that you follow the procedures highlighted below if your operating system can't be upgraded:

  1. Upgrade your existing database server to SQL Server 2008 and migrate your content to it
  2. Install a new server with Windows Server 2008 R2 and the necessary software prerequisites
  3. Copy the necessary files from your Perception 4 or 5 machine to the new server you set up for Perception 5.7
  4. Run the installer and install Perception 5.7
  5. Configure Perception using the configuration application
  6. Create a new ODBC connection to your upgraded/migrated database
  7. Link your old repository up to the Shared Repository Manager
  8. Run the Upgrade Wizard

For information about how to migrate your content to Perception 5.7 in this type of upgrade, please refer to the Upgrade from Perception 4 section of the Questionmark Perception 5.4 Install Guide.

Recommendations for installing from a version of Windows that can be upgraded

If your operating system can be upgraded, it is recommended that you carry out the following steps:

  1. Upgrade your existing database server to SQL Server 2008 R2 and migrate your content to it
  2. Run through the operating system upgrade process
  3. Install the necessary software prerequisites
  4. Run the installer and install Perception 5.7
  5. Configure Perception using the configuration application
  6. Run the Upgrade Wizard

For information about carrying out the upgrade procedure for Perception, please refer to Upgrading from Perception 5.